logo-sm

お電話はこちら 03-6912-0139

ブログ

学習用のCiscoルータを自宅LANに取り込んで快適な検証環境を構築したい

2021.07.30

 

 

 

【はじめに】

初めまして。こんにちは!

今回は、駆け出しネットワークエンジニアが 学習用に実機を購入するまでの経緯と、自宅のLANを介してSSHで接続できる環境をつくるまでをご紹介いたします。

 

【動機】

勉強やお仕事を進めるうえで、ググってもその表層しか拾えなかったりで、いまいち腑に落ちないような気持ちになることが度々ありました。
シュミレータ(仮想的に複数の機器を起動して、自由にネットワークを組めたりします)も色々と制限がありなんとなく馴染まず、やはり実機を買って動かしてみたいなという気持ちが日に日に募っていき…

そして、引っ越しを機に購入することを決めました。 意志や信念が強いタイプではない私のような人間にとって、「環境の変化」は決断の要素としてエース級の活躍をすることが多い気がします。

 

【選定基準】

購入することを考えたとき一番気になったのは、「金額」と「スペース」の2点です。

ただ、金額面の懸念は比較的初期にに解決しました。
初期費はオークションサイトなどで古いモデルを購入することで。維持費は未使用時に機器の電源を落とせば何とか抑えられそうです。

スペースに関しては深刻です。というのも、これまで購入に踏み切らなかった要因として、あまり生活空間で出しゃばらないでほしいという気持ちがあったからです。
そのため、家庭用のルーター(ONUと一体型)やスイッチを置いているワゴンの最下段に収まるサイズのものであればOKという条件を設けました。

上記2点を満たす中で、機能性がある程度あるものを選ぼうという方針で纏まり、数日後に スイッチとしての機能もある程度持つルーターである Cisco 1812J/K9 を3台購入しました。

かかった金額は3台合わせて1万円と少し。古いモデルということもあり、タイミングなど見計らえばもう少し安く買えそうな気もします。
とは言え下手なレンタルサービスを利用するよりは安くすみましたし、やる気があるうちに購入したかったのでこれで良いと自分を納得させました。

 

【構成】

さて、実機が届いたのでいろいろと試していきたいところですが、私はものぐさな性分なので毎回コンソールケーブルで機器にアクセスするのは億劫です。
そのため普段使いのPCと自宅環境をなるべくそのままで機器にSSH接続できるような構成が理想であり、考えた結果以下のようになりました。

 

 

 

【設定】

それではさっそく機器の設定に入りましょう。初期起動時の「Would you like to enter the initial configuration dialog?」に「no」と答えた後は、それぞれの機器に以下の設定を順次投入していきます。

 

 【設定:1812J-001】


# ホスト名とパスワードを設定
enable
configure terminal
hostname 1812J-001
enable password <hoge>
※ <>の部分には、任意の文字列を代入するものと捉えてください。

 

# インターフェイスの設定 
vlan 20
interface vlan 1
ip address 192.168.1.2 255.255.255.0
interface vlan 20
ip address 172.16.20.1 255.255.255.0
interface FastEthernet1
ip address 172.16.10.1 255.255.255.0
no shutdown
interface FastEthernet2
switchport mode access
switchport access vlan 20
no shutdown
interface FastEthernet9
no shutdown

 

# ルーティングの設定 
ip routing
ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

 

 【設定:1812J-002】


# ホスト名とパスワードを設定 
enable
configure terminal
hostname 1812J-002
enable password <hoge>

 

# インターフェイスの設定 
interface FastEthernet1
ip address 172.16.10.2 255.255.255.0
no shutdown

 

# ルーティングの設定 
ip route 0.0.0.0 0.0.0.0 172.16.10.1

 

 

 【設定:1812J-003】


# ホスト名とパスワードを設定 
enable
configure terminal
hostname 1812J-003
enable password <hoge>

 

# インターフェイスの設定 
vlan 20
interface vlan 20
ip address 172.16.20.2 255.255.255.0
interface FastEthernet2
switchport mode access
switchport access vlan 20
no shutdown

 

 【設定:SSH接続設定】

最後に、全ての機器にSSHの設定を投入します。

# 下記の暗号鍵作成手順に必要な諸設定 
ip domain-name <hoge>
username user password <hoge>

 

# SSH接続に必要なRSA暗号鍵の作成と、SSHのバージョン指定 
crypto key generate rsa
2048
ip ssh version 2
※今回は、鍵サイズを2048、SSHバージョンを2に指定しました。

 

# 仮想のポートであるvtyにsshの割り当て
line vty 0 4
transport input ssh
login local

 

# vtyに、作業にあたって便利になるコマンドをいくつか投入
exec-timeout 0 0
logging synchronous
transport preferred none
end

 

【疎通確認】

設定内容の確認と保存が済めば、いよいよ疎通確認です。
PCにてコマンドプロンプトを管理者として起動しルートを追加した後、機器にログインしてみます。

 

route -p add 172.16.10.0 mask 255.255.255.0 192.168.1.2
route -p add 172.16.20.0 mask 255.255.255.0 192.168.1.2

 

無事に接続できました! 一応CDPで隣接している機器の情報を確認しましたが、こちらも想定通りのようです。

 

【さいごに】

最後までお付き合いいただきありがとうございました。
ブログの執筆が初めてだった事もあり思い通り記述できなかったり、家にあるONUと一体型のブロードバンドルーターが経路制御できないものであることに後から気が付いて予定が狂ったりと紆余曲折ありましたが、目標としていた環境を何とか構築できたので今はとにかく安堵しています。

分からない部分をすぐに試せる環境というものは、自分にとって明確にプラスになります。少なくとも不安は減ります。
これからも、こうした取り組みを定期的に行っていこうと思います。

関連記事

  • https(SSL化)してあるのにhttpがgoogle検索にindexされていた時の対処法
    最近私のWordpressのサイトでhttps(SSL化)しているにもかかわらず httpのURLがGoogl […]

    2021.09.29

  • WordPressで使っていないCSSを削除する方法
    ファイルを軽くするために使っていないcssを消す必要がある場合があります。 今回ある仕事で大量にページを削除し […]

    2021.09.29

  • WinMargeで保存時に黒い線が出てきて焦った
    WinMargeはWindowsを使っていれば使ったことある人が多いのではないでしょうか? 最近、現場で働いて […]

    2021.09.29

  • パートナー

  • 人材育成